We are currently monitoring results. If you experienced issues, please retry now. Users may have to retry the approval and e-signature.
Posted Jan 14, 2025 - 12:12 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 14, 2025 - 11:47 PST
Investigating
We want to inform you of a current issue impacting SSO eSignature functionality across our platform. This issue appears unrelated to specific SSO providers and is being actively investigated by our engineering team. While the root cause is not yet confirmed, resolving this issue is our highest priority.
We understand how critical this functionality is to your workflows and are working diligently to minimize disruption. We will keep you updated as we make progress and provide an estimated timeline for resolution as soon as possible.