Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 25, 2025 - 18:00 PDT
Scheduled
To coincide with our Summer ’25 (25R3) release, Propel Software is performing maintenance on our Heroku server beginning at 6:00 PM PT on Friday, July 25th. This is a release to improve Propel Export PDX and will have a brief downtime. For more information or questions please contact the Support Team at support@propelsoftware.com.
Posted Jul 21, 2025 - 13:53 PDT
This scheduled maintenance affected: Propel Export.