Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 03, 2024 - 18:00 PST
Scheduled
Propel Software is performing maintenance on our Heroku server beginning at 6:00pm PDT on Tuesday, December 3rd. This maintenance is required to fix Propel Export and Requirements services and will have a brief downtime. For more information or questions please contact the Support Team at support@propelsoftware.com.
Posted Dec 03, 2024 - 14:40 PST
This scheduled maintenance affected: Propel Export.