Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 02, 2026 - 18:00 PDT
Scheduled
Propel Software will be performing a minor maintenance operation commencing at 6:00 pm PT on Tuesday, June 2nd. This maintenance is intended to enhance document generation services and will result in a brief period of downtime. For further information or inquiries, please contact the Support Team at support@propelsoftware.com.
Posted Jun 01, 2026 - 14:59 PDT
This scheduled maintenance affected: PDF Generation Service.